Uninstall Millenaire from a server?

Discuss Millénaire in English
Post Reply
katzevonstich
Posts: 1
Joined: Wed Jul 23, 2014 7:20 am

Uninstall Millenaire from a server?

Post by katzevonstich » Wed Jul 23, 2014 7:40 am

I have a server running Forge and several mods along with Millenaire. This is a server through a host, as my home server doesn't have the specs to run more than vanilla MC. The specs on the hosted server are good, but after installing Millenaire, I began having instability problems. Any new chunk loaded that had a Millenaire village or building would result in a server crash. Clicking on some villagers and trying to place some scrolls would cause the same problem. Tonight, clicking on a villager in a new village caused a crash with "internal server error."

As much as my players like the mod (I play it in SP all the time), there's so many crashes, the server is almost unplayable. It only started happening after Millenaire was installed, so we are confident that it's conflicting with something else. I tried removing the files from the server's mods folder as I was instructed in another forum, but that rendered the server unable to start due to several of these errors ( server thread/INFO [FML]: Found a missing id from the world millenaire ). I restored the files and changed the config file to not generate new villages or single buildings, but the crashing problem still remains.

Is there a way to uninstall, remove, or disable Millenaire from the server without the missing ID errors that prevent the server from starting?

I know there's something out there about editing block IDs, but I'm a complete learn-as-I-go-newbie to the server side of mods and barely know what half the threads are talking about.

Thanks!

zohar101
Posts: 11
Joined: Mon Aug 26, 2013 1:47 am

Re: Uninstall Millenaire from a server?

Post by zohar101 » Fri Jul 25, 2014 12:57 pm

I'd say you gotta clear out all the millenaire blocks from your server if you don't want it to give you missing ID errors afterwards. Get MCEdit and also NotEnoughItems (to find their IDs). Then follow instructions outlined here for a similar problem:
http://forum.industrial-craft.net/index ... eadID=8025
I'd also make sure you delete the millenaire folder from your save/data folder first, and see if it helps.

ProsperCraft
Posts: 94
Joined: Sat Aug 03, 2013 5:22 pm
Contact:

Re: Uninstall Millenaire from a server?

Post by ProsperCraft » Sat Aug 02, 2014 5:44 am

In my multiple failed attempts(because I just couldn't admit the 5.2 version was broken, I really love this mod) at using the 1.7.2 version that is broken I have had to disable the mod and the server continues just fine.

change the millionaire jar file in your mods folder to .jar.disabled then restart the server, it forge will ask you in the terminal if you want to remove all blocks from that mod and you have to type fml confirm, then the server will start up, the villages will still be there without any modded blocks.

If you want to rescue the mod, I found that some of the crashes on village creation were solved by putting blocks in the blacklist for the villages, like thaumcraft nodes, and gravestones(from the gravestones mod). Thaumcraft nodes were the biggest problem, they should prolly be added to the default blacklist.

Post Reply