[Bug] The idling lumberjack

Locked
Derisen
Posts: 11
Joined: Fri Oct 17, 2014 11:33 am

[Bug] The idling lumberjack

Post by Derisen » Fri Oct 17, 2014 12:05 pm

Hi everyone,
I've recently been expriencing some strange bug in a japanese village : both two lumberjacks are idling all day and no Timber Frame is produced anymore so I can't upgrade the village anymore... Anyone knows how to make these lazy workers work again ?
Thanks ! :D

MoonCutter2B
Posts: 228
Joined: Tue Jun 11, 2013 5:56 am

Re: [Bug] The idling lumberjack

Post by MoonCutter2B » Fri Oct 17, 2014 3:27 pm

Do they have materials to craft some axes?
Try crafting a few stone axes and sell them in the town halll and see if that works.
What version are you using?
the new 6.0beta contains some noce bug fixes.

Derisen
Posts: 11
Joined: Fri Oct 17, 2014 11:33 am

Re: [Bug] The idling lumberjack

Post by Derisen » Fri Oct 17, 2014 3:41 pm

Hey, I'm using the 5.2 version
I've been selling them a few stacks of iron and a few axe but they still do nothing...
Do you have any idea ? :?:

MoonCutter2B
Posts: 228
Joined: Tue Jun 11, 2013 5:56 am

Re: [Bug] The idling lumberjack

Post by MoonCutter2B » Fri Oct 17, 2014 5:31 pm

Chests full?
No wifes?
They might need rice to do frames, I'm not sure about that, but check the same stuff.

Derisen
Posts: 11
Joined: Fri Oct 17, 2014 11:33 am

Re: [Bug] The idling lumberjack

Post by Derisen » Fri Oct 17, 2014 6:51 pm

Most of their chests are empty, they all have wives and plenty of rice... But when I try to trade at the Town All it shows "Missing Item : 0"...

MoonCutter2B
Posts: 228
Joined: Tue Jun 11, 2013 5:56 am

Re: [Bug] The idling lumberjack

Post by MoonCutter2B » Sat Oct 18, 2014 7:07 am

I would try to re-install millenaire.
It looks like one or more of your files are corrupt and with a little luck re-installing the Mill might help.
Make a backup of everything first so you can restore/reapply if needed.

xDemonCrip
Posts: 7
Joined: Sun Sep 07, 2014 12:49 am

Re: [Bug] The idling lumberjack

Post by xDemonCrip » Sat Oct 18, 2014 7:08 am

The lumberjacks in millenaire have really bad AI. In norman towns lumberjacks get stuck on the fence for about 30 seconds before they teleport over even though there is a fence gate, sometimes they will go into the grove and just sit there, and I have noticed that lumberjacks dont upgrade their axes anymore they only stay with wooden.

Derisen
Posts: 11
Joined: Fri Oct 17, 2014 11:33 am

Re: [Bug] The idling lumberjack

Post by Derisen » Sat Oct 18, 2014 6:26 pm

How could I find the corrupted file ? I don't want to reset all the map since I've been working a lot on different villages... If I can't I'd just wait for an other version and start over again ^^'

MoonCutter2B
Posts: 228
Joined: Tue Jun 11, 2013 5:56 am

Re: [Bug] The idling lumberjack

Post by MoonCutter2B » Sat Oct 18, 2014 8:10 pm

No, no :)
I'm takling about installng a fresh copy of Millenaire only.
I.e. just replacing the millenaire-5.2.jar and the millenaire folder with a fresh copy, both are inside the mods folder. Leave everything else as they are.

And to be safe make a backup of the .minecraft folder before you do anything or at least your saved game(s) in the saves folder.

I'm still not sure this help. If youre saved game is corrupt (god forbid) then its not much to do :(

Locked