Page 1 of 1

Lumberjack's AI seizes up often

Posted: Mon Dec 30, 2013 10:35 pm
by SirKline
I noticed the the lumberjack AI freezing up frequently, it would set itself to cut wood move to a spot and do nothing, pushing it 1-3 times usually jumpstarts it back up, but still would rather not babysit. I've witnessed it freezing up a few time trying to return goods and collect them. Was using Java 1.7.0.25 just got updated to .45 maybe that will help, not counting it though. MC version 1.6.4 (as if there is anything later atm), and latest version of millenire.

Update: hmm oops was using Openjdk instead of commerical java I'll put a hold on this for the moment to see if the ai still behaves like so.

Re: Lumberjack's AI seizes up often

Posted: Mon Jan 13, 2014 9:14 pm
by Teethdude
Even with Oracle's Java I noticed this too. However, I don't know what causes it

Re: Lumberjack's AI seizes up often

Posted: Tue Jan 14, 2014 12:51 am
by druha
Teethdude wrote:Even with Oracle's Java I noticed this too. However, I don't know what causes it
I believe the pathing has trouble figuring out how to get close enough to cut the tree. I suspect that fences and fence gates confuse it due to not being full solid blocks.

Re: Lumberjack's AI seizes up often

Posted: Tue Jan 14, 2014 3:49 pm
by Tairgire
Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)

Re: Lumberjack's AI seizes up often

Posted: Tue Jan 14, 2014 5:23 pm
by Teethdude
Tairgire wrote:Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)
Yeah this happens in all the cultures

Re: Lumberjack's AI seizes up often

Posted: Fri Jan 17, 2014 5:27 pm
by felinoel
Tairgire wrote:Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)
This issue was why that option was made. /: