Lumberjack's AI seizes up often

Locked
SirKline
Posts: 10
Joined: Mon Dec 30, 2013 10:10 pm

Lumberjack's AI seizes up often

Post by SirKline » Mon Dec 30, 2013 10:35 pm

I noticed the the lumberjack AI freezing up frequently, it would set itself to cut wood move to a spot and do nothing, pushing it 1-3 times usually jumpstarts it back up, but still would rather not babysit. I've witnessed it freezing up a few time trying to return goods and collect them. Was using Java 1.7.0.25 just got updated to .45 maybe that will help, not counting it though. MC version 1.6.4 (as if there is anything later atm), and latest version of millenire.

Update: hmm oops was using Openjdk instead of commerical java I'll put a hold on this for the moment to see if the ai still behaves like so.

User avatar
Teethdude
Posts: 118
Joined: Sun Jun 09, 2013 7:52 pm
Location: Canada
Contact:

Re: Lumberjack's AI seizes up often

Post by Teethdude » Mon Jan 13, 2014 9:14 pm

Even with Oracle's Java I noticed this too. However, I don't know what causes it

User avatar
druha
Posts: 275
Joined: Sat Jul 20, 2013 10:09 pm

Re: Lumberjack's AI seizes up often

Post by druha » Tue Jan 14, 2014 12:51 am

Teethdude wrote:Even with Oracle's Java I noticed this too. However, I don't know what causes it
I believe the pathing has trouble figuring out how to get close enough to cut the tree. I suspect that fences and fence gates confuse it due to not being full solid blocks.

Tairgire
Posts: 3
Joined: Tue Jan 14, 2014 3:45 pm

Re: Lumberjack's AI seizes up often

Post by Tairgire » Tue Jan 14, 2014 3:49 pm

Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)

User avatar
Teethdude
Posts: 118
Joined: Sun Jun 09, 2013 7:52 pm
Location: Canada
Contact:

Re: Lumberjack's AI seizes up often

Post by Teethdude » Tue Jan 14, 2014 5:23 pm

Tairgire wrote:Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)
Yeah this happens in all the cultures

User avatar
felinoel
Posts: 974
Joined: Sun Jun 09, 2013 6:02 pm

Re: Lumberjack's AI seizes up often

Post by felinoel » Fri Jan 17, 2014 5:27 pm

Tairgire wrote:Furthering that theory, I've noticed that switching the pathing mode to classic nearly always fixes him. At first, I could switch and then switch back, but it seems like lately I need to leave it on Classic if I want my lumberjacks to work. This is in a Japanese village, though I think I noticed this in another village recently (but didn't stay as long.)
This issue was why that option was made. /:

Locked